[SOLVED] Setup/install on IIS 8 (WonderCMS 2.5.2)

Post Reply
skna
Posts: 1
Joined: Mon Aug 20, 2018 9:19 am

[SOLVED] Setup/install on IIS 8 (WonderCMS 2.5.2)

Post by skna »

Hi community!

So, today I tried a clean install of WonderCMS 2.5.2 on an IIS 8 server with PHP 5.5 installed (and cURL & mod rewrite 2.1 modules, supposedly).

The WonderCMS is in the subfolder of inetpub\wwwroot\wonder.

web.config:

<match url="^(.+)$" />
<action type="Rewrite" url="/wonder/index.php?page={R:1}" appendQueryString="true" />
</rule>
<rule name="rule 2S">
<match url="database.js" />
<action type="Rewrite" url="/-" />
</rule>
</rules>
</rewrite>
</system.webServer>
</configuration>

Most of the pages in the default installation seem to work just fine, but some clicks seem to result in HTTP error 500 or just a blank page / no function.

I seem to be able to log in, but the "logout" link seems to just give me a blank page and do nothing. Opening the /wonder index page shows that I am still logged in as admin.

Also, trying to change the default admin password or login URL in Settings do not seem to work, and neither does trying to make changes to the content pages. As if the system can't write to the .js database. Looking at the file permissions of database.js, everything looks fine for the IUSR and IIS_Users. Write, Modify, all enabled.

Any ideas as to how to troubleshoot the problem? Thanks! :)


Edit: Actually it now seems that updating PHP to 5.6 fixed the problems I describe above. If they reappear, I'll get back to the thread.
wiz
Admin
Posts: 495
Joined: Sat Oct 30, 2010 12:23 am

Re: [Solved] Setup/install on IIS 8 (WonderCMS 2.5.2)

Post by wiz »

Hi skna and welcome to the WonderCMS community.

Kudos for figuring out what the problem was!
A huge thanks for posting the solution and marking the thread as solved, I'm sure someone will find the information you posted useful.

If you need anything, drop another message and we'll be happy to help.
Post Reply