[SOLVED] Trying to install - The requested URL was not found on this server.

Ask for help or provide support to other members.
Post Reply
helmutwinkelbach
Posts: 2
Joined: Fri Jul 29, 2022 4:48 am

[SOLVED] Trying to install - The requested URL was not found on this server.

Post by helmutwinkelbach »

Hi, i'm trying WonderCMS on a Apache24 server with PHP 8.0 with a standard installation of WonderCMS 3.3.4 with cacert.pem in the root (htdocs folder)

I can see on my URl http://localhost:8080
Welcome to your website, Your password for editing everything is: ...

But if i CLICK HERE TO LOGIN, i get the following error:
The requested URL was not found on this server.

THANKS for any help and support!

My Apache Error log
The 'Apache2.4' service has restarted.
winnt:notice] [pid 10716:tid 428] AH00424: Parent: Received restart signal -- Restarting the server.
[Fri Jul 29 08:03:45.336429 2022] [mpm_winnt:notice] [pid 10716:tid 428] AH00455: Apache/2.4.54 (Win64) PHP/8.0.21 configured -- resuming normal operations
[Fri Jul 29 08:03:45.336429 2022] [mpm_winnt:notice] [pid 10716:tid 428] AH00456: Apache Lounge VS16 Server built: Jun 22 2022 09:58:15
[Fri Jul 29 08:03:45.336429 2022] [core:notice] [pid 10716:tid 428] AH00094: Command line: 'C:\\Apache24\\bin\\httpd.exe -d C:/Apache24'
[Fri Jul 29 08:03:45.336429 2022] [mpm_winnt:notice] [pid 10716:tid 428] AH00418: Parent: Created child process 12940
[Fri Jul 29 08:03:46.329845 2022] [mpm_winnt:notice] [pid 12940:tid 400] AH00354: Child: Starting 64 worker threads.
[Fri Jul 29 08:03:47.335342 2022] [mpm_winnt:notice] [pid 11368:tid 424] AH00364: Child: All worker threads have exited.

My PHP Version 8.0.21

System Windows NT GEFLLT1121 10.0 build 19044 (Windows 10) AMD64
Build Date Jul 6 2022 11:19:11
Build System Microsoft Windows Server 2019 Datacenter [10.0.17763]
Compiler Visual C++ 2019
Architecture x64
Configure Command cscript /nologo /e:jscript configure.js "--enable-snapshot-build" "--enable-debug-pack" "--with-pdo-oci=..\..\..\..\instantclient\sdk,shared" "--with-oci8-19=..\..\..\..\instantclient\sdk,shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--without-analyzer" "--with-pgo"
Server API Apache 2.0 Handler
Virtual Directory Support enabled
Configuration File (php.ini) Path no value
Loaded Configuration File C:\php\php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20200930
PHP Extension 20200930
Zend Extension 420200930
Zend Extension Build API420200930,TS,VS16
PHP Extension Build API20200930,TS,VS16
Debug Build no
Thread Safety enabled
Thread API Windows Threads
Zend Signal Handling disabled
Zend Memory Manager enabled
Zend Multibyte Support provided by mbstring
IPv6 Support enabled
DTrace Support disabled
Registered PHP Streams php, file, glob, data, http, ftp, zip, compress.zlib, https, ftps, phar
Registered Stream Socket Transports tcp, udp, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2, tlsv1.3
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, convert.*, consumed, dechunk, zlib.*
OneManLaptop
Developer
Posts: 64
Joined: Tue Mar 16, 2021 3:29 pm

Re: Trying to install - The requested URL was not found on this server.

Post by OneManLaptop »

Hey: helmutwinkelbach

Thanks for giving Wonder CMS a look, sorry to hear about the problems you're having!

I had the same problem with the 3.3.2 release but 3.3.4 has fixed it for me. You're absolutely certain you're running the latest version of WCMS? If you take a fresh install and run it elsewhere on your server are you getting the same result?

If that doesn't work, could you copy the full URL before you login and then copy it again when you're getting the error. What happened previously is that it was duplicating the :8080 portion of the URL. You can see the report I made about it here:

viewtopic.php?t=3256

Let us know the answer to those questions and I'm sure wiz will be along to enquire further.
helmutwinkelbach
Posts: 2
Joined: Fri Jul 29, 2022 4:48 am

Re: Trying to install - The requested URL was not found on this server.

Post by helmutwinkelbach »

Hey: OneManLaptop, thanks for your answer. Still no success.
Yes i use 3.3.4 and i can always go back to http://localhost:8080, but https://localhost:8080 gives SSL_ERROR.

In the index.php i did change the ports:
$serverPort = ((($_SERVER['SERVER_PORT'] == '8080') || ($_SERVER['SERVER_PORT'] == '8443')) ? '' : ':' . $_SERVER['SERVER_PORT']);

I think folder permission is also OK.

Any hint whould be welcome
User avatar
wiz
Admin
Posts: 703
Joined: Sat Oct 30, 2010 12:23 am

Re: Trying to install - The requested URL was not found on this server.

Post by wiz »

Hello helmutwinkelbach, thanks for dropping by!

1. Can you specify what your folder permissions are?
2. If the htaccess file present in the same folder as your index.php?
3. What happens if you open http://localhost:8080?page=loginURL
4. Can you try any other CMS to ensure your SSL cert is setup correctly?

There might be more questions based on your answers before we figure out what the issue is.
lyman123
Posts: 2
Joined: Tue Sep 27, 2022 9:53 pm

Re: Trying to install - The requested URL was not found on this server.

Post by lyman123 »

I have the same issue.

When I login, I get URL not found for this URL: 10.0.2.15/loginURL

However, if I change it to 10.0.2.15/?page=loginURL, then I get a proper login page, but when I submit, I get the same/loginURL page with the not found error.

ENVIRONMENT

Xubuntu 22.04

Apache2
with Mod_rewrite

I'm running PHP 8.1 with
cURL extension
mbstring extension
Zip extension

(all validated in the Apache/PHP info screens)

File permissions 755.

and Wonder CMS 3.3.4

Any help would really be appreciated, we need a one page website and this seems to fit the bill if we can get it runnning.
User avatar
wiz
Admin
Posts: 703
Joined: Sat Oct 30, 2010 12:23 am

Re: Trying to install - The requested URL was not found on this server.

Post by wiz »

Hello lyman.

Since example.com/?page=loginURL works for you, it indicates that theres an issue either with:
- missing .htaccess (in the same folder as index.php)
- missing mod_rewrite module or it being disabled
- do you have an SSL certificate installed?
lyman123
Posts: 2
Joined: Tue Sep 27, 2022 9:53 pm

Re: Trying to install - The requested URL was not found on this server.

Post by lyman123 »

wiz wrote: Wed Sep 28, 2022 12:41 am Hello lyman.

Since example.com/?page=loginURL works for you, it indicates that theres an issue either with:
- missing .htaccess (in the same folder as index.php)
- missing mod_rewrite module or it being disabled
- do you have an SSL certificate installed?
This is a local VM, so I don't have a SSL certificate installed.

I was thinking mod_rewrite might be the culprit (I have .htaccess installed - although maybe I don't have all the settings correctly set - do you have a posting with the recommended .htaccess settings). The Apache2 defaut response page indicates that mod_rewrite is enabled, unless there are any special flags for it. Everything is pretty much at default.

Note, I had to enable the d\short tags to get this to even run, but that's set now.

Thanks. I'll take a closer look at mod_rewrite.
Post Reply