[SOLVED] Login on local installation

Ask for help or provide support to other members.
Post Reply
netzsegler
Posts: 3
Joined: Wed Dec 09, 2020 1:30 pm

[SOLVED] Login on local installation

Post by netzsegler »

Hello

I am trying to test wondercms on a local windows WAMP installation and I am afraid I need some assistance....

I use the Uniformserver Zero 14. (Apache/2.4.43 (Win32) PHP/7.4.5 ) - http://www.uniformserver.com/
After activating CURL I can see the homepage with the generated password.
But when I click on the "Login" link the page cannot be displayed because of a page not found error, which is obvious becuase the link is "http://localhost//loginURL" ...

Because I found these hints in another post:
- yes I can access the login page when I manually open http://localhost/?page=loginURL but then fail for the next page when I enter the password shown
- yes ModRewrite is enabled

Any idea how I can fix this ?

Thanks a lot and best regards
netzsegler
User avatar
wiz
Admin
Posts: 569
Joined: Sat Oct 30, 2010 12:23 am

Re: Login on local installation

Post by wiz »

Hi netzsegler.

It seems WAMP should support clea URLs out of the box.
1. Have you uploaded the .htaccess file that's included in the WonderCMS package?
2. If you have enabled mod_rewrite after installing WonderCMS, the server needs to be restarted.
3. Have you used any other CMS that had working clean URLs on your WAMP server?

Let me know and we'll try to help you out based on the answers you've provided.
netzsegler
Posts: 3
Joined: Wed Dec 09, 2020 1:30 pm

Re: Login on local installation

Post by netzsegler »

Hi wiz,

thanks for taking care about my issue!

1. yes I first uploaded the .htaccess files that came with the WonderCMS package. But then I got an 403 ERROR - Forbidden. You don´t have access to this ressource. So I renamed the file to getthe results initially posted. Probably that´s the reason for the misbehaviour.

2. Although ModRewrite was enabled out of the box with the Uniform WAMP I restarted the server - unfortunately it didn´t help.

3. no other CMS so used locally far.

Edit: just found this in the error log:

Code: Select all

[Mon Dec 14 10:32:46.933906 2020] [rewrite:error] [pid 19724:tid 1964] [client ::1:52968] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : C:/Users/xxxxx/Downloads/uniform/UniServerZ/www/favicon.ico, referer: http://localhost/
BR
netzsegler
netzsegler
Posts: 3
Joined: Wed Dec 09, 2020 1:30 pm

Re: Login on local installation

Post by netzsegler »

Solved:

just add:

Code: Select all

Options +FollowSymLinks
at the end of the .htaccess file.

BR
netzsegler
User avatar
wiz
Admin
Posts: 569
Joined: Sat Oct 30, 2010 12:23 am

Re: [SOLVED] Login on local installation

Post by wiz »

Hi netzsegler.

Thanks for posting back and providing a solution for anyone that might run into this issue.
If you want to help us improve WonderCMS even further, we would love any feedback that you might have on anything.

As a thank you, we would also add you to our special list of contributors: https://www.wondercms.com/special-contributors
Post Reply