[SOLVED] HTML edit mode not align left

Ask for help or provide support to other members.
Post Reply
kimku
Posts: 9
Joined: Sun Nov 29, 2020 6:50 am

[SOLVED] HTML edit mode not align left

Post by kimku »

all goes to center!
editmodehtml.png
editmodehtml.png (11.78 KiB) Viewed 3384 times
User avatar
wiz
Admin
Posts: 569
Joined: Sat Oct 30, 2010 12:23 am

Re: HTML edit mode not align left

Post by wiz »

Hi kimku.

What theme are you trying to use? Can you share it so we can investigate?
This boils down to being faimilar with CSS and aligning the content to the left.
kimku
Posts: 9
Joined: Sun Nov 29, 2020 6:50 am

Re: HTML edit mode not align left

Post by kimku »

Default theme (from WonderCMS 2.7.0)
User avatar
wiz
Admin
Posts: 569
Joined: Sat Oct 30, 2010 12:23 am

Re: HTML edit mode not align left

Post by wiz »

Default theme uses centered content.

If you want the content to be left aligned:

1. Open theme.php on your server for the default theme.
2. Remove "text-center" in the following div.

Code: Select all

<div class="col-lg-12 text-center padding40">
3. Save.
4. Theme content will be left aligned.

Note: This is not a bug, marking thread as solved.
kimku
Posts: 9
Joined: Sun Nov 29, 2020 6:50 am

Re: [SOLVED] HTML edit mode not align left

Post by kimku »

I don't use any WYSIWYG html editor plugin.

WonderCMS 2.7.0 have not this problem, it is left aligned in [edit] mode.
I only found this problem when I upgrade to WonderCMS 3.1.3

I think in [edit] mode all text should be aligned to the left, just like a normal text editor (NotePad).
In [display] mode it is depended theme's CSS
User avatar
wiz
Admin
Posts: 569
Joined: Sat Oct 30, 2010 12:23 am

Re: [SOLVED] HTML edit mode not align left

Post by wiz »

It seems the theme might have been updated in the meantime (between 2.7.0 and 3.1.3).

If you follow the instructions I posted above, it should work without any issues.
kimku
Posts: 9
Joined: Sun Nov 29, 2020 6:50 am

Re: [SOLVED] HTML edit mode not align left

Post by kimku »

what I want is:

the content to be center aligned.
but in [edit/code] mode, it is left aligned.
Post Reply