HTTP 500 Error

Post Reply
KC9SWV
Posts: 3
Joined: Wed May 24, 2017 12:43 pm

HTTP 500 Error

Post by KC9SWV »

Greetings All,

I'm having an issue with trying to install wCMS in a subdirectory and getting an HTTP 500 error.

We're on shared hosting, but it's free since we're non-profit so I can't complain much. I created a subdirectory called /test/ to install wCMS in before pushing live after configuration. I cannot get anything but an HTTP 500 to happen when attempting to browse to www.mywebsite.org/test/

I have checked all the permissions and the files are 644, directories are 755.

I tried changing index.php and .htaccess as recommended in the .htaccess problems thread below. No joy.

I also tried using the original index.php and .htaccess and adding BaseRewrite /test/ without any luck either.

Our server is a FreeBSD 7.0 server running Apache 2.2.21 and PHP 5.3.8. Any thoughts on what I can do to make this work in a subdirectory?

Thanks,
Morgen
KC9SWV
Posts: 3
Joined: Wed May 24, 2017 12:43 pm

Re: HTTP 500 Error

Post by KC9SWV »

Update: Ugh, we don't have cURL installed. I think that's likely the problem.

Now to see if I can work around it by manually fetching some files.
User avatar
wiz
Admin
Posts: 569
Joined: Sat Oct 30, 2010 12:23 am

Re: HTTP 500 Error

Post by wiz »

Hello and welcome to the community.

Besides cURL, you'll also need PHP version 5.5 or greater, you're unfortunately a version or so behind for WonderCMS to function correctly.
- PHP mbstring extension (besides PHP cURL extension).
- support for htaccess (Apache Module mod_rewrite)
https://github.com/robiso/wondercms/wiki/Requirements

Even if you solve some of the cURL issues by using file_get_contents instead, there could be additional problems.
If you're just looking for a WonderCMS version that uses file_get_contents, check out how it worked before we moved to cURL:
https://github.com/robiso/wondercms/com ... 7f9ced07a2

Please note that changing the index.php and using the "One click update" feature later overwrites your index.php, so you might also want to take that part out of the code.

Hope this helps, if you need any more assistance I'll be glad to help.

Even though your hosting package is free, you might want to check if you're eligible for any updates (although I understand it's almost crazy to ask for additional "updates" on free packages.
KC9SWV
Posts: 3
Joined: Wed May 24, 2017 12:43 pm

Re: HTTP 500 Error

Post by KC9SWV »

Thanks so much for your help on this. I reverted everything in the commit you linked back to using get_file_contents instead of cURL and removed the update and getversion sections of the code and the calls to them in the init section.

I'm still getting HTTP 500 errors, so I assume there must be something else that's not quite right.

I started writing my own lightweight PHP CMS a while back and asked for file_upload to be enabled and just today, 5 weeks later, got the response that the admin had done that. So, I'm not holding my breathe for updating PHP any time soon.

I don't have any real development environment setup, I made our current website by hand coding PHP and CSS in Notepad and uploaded to our webhost for testing... I'm the epitome of a newb when it comes to all this, but your CMS was EXACTLY what I was trying to accomplish so I'd love to get this working with our current setup.

I check phpinfo() and we have mod_rewrite enabled, so I wouldn't think that it's an .htaccess problem... any other thoughts as to what might be wrong that prevents the code from running on PHP 5.3.8?
User avatar
wiz
Admin
Posts: 569
Joined: Sat Oct 30, 2010 12:23 am

Re: HTTP 500 Error

Post by wiz »

Thank you, really glad you like it. I completely understand that your host is slow to action on these things..

Additionally, you'll need to check if you have the PHP mbstring extension.

What happens if you try to rename .htaccess to something else temporarily and try to visit your website at yoursite.com/wonderCMSlocation/index.php?page=home and if that doesn't work, it's probably the missing mbstring PHP extension.

Report back about the mbstring and renaming .htaccess and we can work from there.
Post Reply