Site working on one host, but when moved over, nothing works

Post Reply
autodefrost
Premium User
Posts: 9
Joined: Sun Feb 16, 2014 7:06 pm

Site working on one host, but when moved over, nothing works

Post by autodefrost »

I have the site working on one host http://khaus.com/sandbox/RamblewoodSoccer/, however when i move it to its new home/host, the links do not work. http://gator3241.hostgator.com/~ramble/

Ive tried uploading a clean/unedited version of the WCMS, http://gator3241.hostgator.com/~ramble/2014/, and i get the same 404/not found message for the 'Example' link....

Is there something that i'm overlooking to edit/change when uploading to the new host, to prohibit the new pages from working? :|
wiz
Admin
Posts: 481
Joined: Sat Oct 30, 2010 12:23 am

Re: Site working on one host, but when moved over, nothing w

Post by wiz »

I'm pretty certain this is because (either) of a missing .htaccess file or hostgator not supporting .htaccess files for your hosting package.
Check if your ~ramble/ installation of WonderCMS has the required .htaccess file (which enables clean URLs).

If it's there, your other option is to contact your hosting provider to see what's up with .htaccess files.

(The .htaccess file comes with the default installation of WonderCMS, if you don't see it, you should enable to "view hidden files" in your windows.)

EDIT

It's definitely the .htaccess file (without it, your URL would have to look like: http://gator3241.hostgator.com/~ramble/?page=sponsors - and this works) - this is how we can pinpoint the problem to the .htaccess file.

Once you put the .htaccess into the WonderCMS folder (or your provider enables it) it will work perfectly fine.
autodefrost
Premium User
Posts: 9
Joined: Sun Feb 16, 2014 7:06 pm

Re: Site working on one host, but when moved over, nothing w

Post by autodefrost »

hmm..
There is an .htaccess file there, uploaded with a fresh copy of wondercms.zip.

The permissions are set to 644, and the htaccess file has this content:
<Files password>
order allow,deny
deny from all
</Files>
Options +FollowSymLinks
Options +Indexes
RewriteEngine on
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteRule ^([^\.]+)$ ?page=$1 [NC,L]
wiz
Admin
Posts: 481
Joined: Sat Oct 30, 2010 12:23 am

Re: Site working on one host, but when moved over, nothing w

Post by wiz »

I noticed you changed your links to ?page= to make them work. I'm still eager to fix this problem, as clean URLs are always nice (for both SEO and the eye).

I visited /files on your site and it returned forbidden (403) which means the .htaccess works.
The next best guess is that problem lies within .htaccess. I think it's unable to specify the correct path of WonderCMS, thus not creating/rewritting the URLs correctly.

Do you mind trying this out (quote from another developer)
xss wrote: EDIT: In cases where WonderCMS does not run from the root folder of a domain, you will have to change the ‚RewriteBase‘ line to something like this:

Code: Select all

RewriteBase /path/to/wondercmsfolder/
If this doesn't work, we'll explore other options.
Post Reply