[SOLVED] I'm missing something I know!!!

Post Reply
MikeR
Posts: 2
Joined: Thu Oct 04, 2012 12:42 pm

[SOLVED] I'm missing something I know!!!

Post by MikeR »

Hi all
Im sure I must be missing something.
I have Wonder CMS set up in a directory ( /wonder )

Index loads, I can log in, I can make changes to the page wonder/files/Home, I can save the changes.

Nothing else works though. I can't add pages, I can't access the example page - the browser attempts to load the page at domain/wonder/Example - obviously giving me a 404 as this isnt the correct path.

I can create text files in the files directory but none of them are read into the menu or made available for editing. I have set permissions for the files directory and its contents to 777 (in desperation) but no joy.

What am I missing - something obvious I'm sure :)

thanks all.

Update:

Have uploaded to root and set permissions on all files to 777 to test. Exactly same issues as previously. Index page functions in as much as I can edit and save the content of Home, but nothing else.
wiz
Admin
Posts: 481
Joined: Sat Oct 30, 2010 12:23 am

Re: I'm missing something I know!!!

Post by wiz »

Hey MikeR!

Mind giving out a link so I can test this out and pinpoint the problem?
Maybe there's something wrong with your .htaccess, but I can't say for sure.

It does sound like there could be a problem with the permissions (even though you changed them to 777).

You can post your link here or PM it to me.
MikeR
Posts: 2
Joined: Thu Oct 04, 2012 12:42 pm

Re: I'm missing something I know!!!

Post by MikeR »

Hi Rob, thanks Have sent you a PM.
wiz
Admin
Posts: 481
Joined: Sat Oct 30, 2010 12:23 am

Re: I'm missing something I know!!!

Post by wiz »

Hey Mike!

Replied to your PM. I think this is a .htaccess issue, since you don't see it. Like I said in my PM, make sure to enable "hidden" files on your machine.
You'll see the .htaccess then, and you'll be able to upload it to your server.
wiz
Admin
Posts: 481
Joined: Sat Oct 30, 2010 12:23 am

Re: I'm missing something I know!!!

Post by wiz »

I'm posting an update since Mike and me figured this out.

Looks like URL rewriting wasn't enabled at his server/host. For situations like this (where you can't have clean URLs enabled), there's a fix.

1. Open up the file named "editText.php" (where you have your WonderCMS installed)
2. Go to line 114, and replace the WHOLE first line of code with the second one.

Code: Select all

echo "$stags href='$page'>$page $etags \n";

Code: Select all

echo "$stags href='?page=$page'>$page $etags \n";
That's it. WonderCMS will now work without clean URLs.
Whenever you switch your host or ask them to enable clean URLs later, just replace these two lines again and it will work flawlessly.
Post Reply