[SOLVED] The editor is stripping tags.

Post Reply
jetshack
Premium User
Posts: 9
Joined: Wed May 30, 2012 8:47 pm

[SOLVED] The editor is stripping tags.

Post by jetshack »

I'm really liking WonderCMS. I've been looking for a simple way to have my 9th graders turn in their labs and practicals online. I think Wonder might do it.

But I've run into a couple of snags. One big one.

I need the ability to use tables. Not for layout issues... but for their specified use. Every assignment my students turn in will have at least 2 data tables.

However, the editor is stripping out the tags for them, all the table related tags i.e. <tr>, <td>, <table> etc...

I've hunted through every file in the cms zip and I can't find a spot where it specifies allowed tags... that's not to say that it's not there somewhere but just that I cant find it.

Any thoughts?

(testbed is located at 101.lionscience.com)
Last edited by jetshack on Fri Jun 01, 2012 4:40 am, edited 1 time in total.
jetshack
Premium User
Posts: 9
Joined: Wed May 30, 2012 8:47 pm

Re: The editor is stripping tags.

Post by jetshack »

ok... so I was able to figure this out. sort of.

I guess i just missed the spot in the edittext.php where the allowed tags are.
I've added the table tags in.

So the tables are being generated, but there are huge amounts of white space preceding each table.

here's a link to what I'm talking about.
http://101.lionscience.com/?page=Reaction%20Time

I've got the feeling that this is related to the reason why you don't have to surround text in <p> and </br> tags. I suspect the <tr> tag is doing it.
jetshack
Premium User
Posts: 9
Joined: Wed May 30, 2012 8:47 pm

Re: The editor is stripping tags.

Post by jetshack »

just read through one of the other threads... and see that this has been addressed.

I'll try that work around tomorrow. If it fixes my problem I'll call this solved.

Thanks.
wiz
Admin
Posts: 514
Joined: Sat Oct 30, 2010 12:23 am

Re: [SOLVED] The editor is stripping tags.

Post by wiz »

I checked out your project site, I looked at the source code and saw that you haven't defined the width of the <td> part.
You specified the width of the main table, but not the td's, so it automatically makes all three equally wide.

Something like this should make it work.

Code: Select all

<table align="center" border="1" cellpadding="1"  width="500">
<tr>
 <td width="100">Student Name</td>
 <td width="200">Gender</td>
 <td width="200">Reaction Time</td>
</tr>
<tr>
 <td width="100">Rob</td>
 <td width="200">Male</td>
 <td width="200">Over 9 hours</td>
</tr>
</table>
I previewed this code on onlinehtmleditor.net
Post Reply