[SOLVED] Installing on XAMPP for OSX

Post Reply
jinesh
Posts: 3
Joined: Fri May 11, 2012 8:07 pm

[SOLVED] Installing on XAMPP for OSX

Post by jinesh »

hello,

on my local machine running XAMPP 1.7.3, I kept getting a Server Error 500 for all pages. Fiddling around with the .htaccess got it working though...

commented out these two lines -

Code: Select all

# Options +FollowSymLinks
# Options +Indexes
& added a rewrite base (mentioned in a previous post by @XSS) -

Code: Select all

RewriteBase /path/to/wondercmsfolder/
Hope this helps new wondercms users :)

p.s. I tried adding 'Allowoverride All' but it didn't work either.
xss
Support/Developer
Posts: 22
Joined: Thu May 26, 2011 9:07 pm

Re: Installing on XAMPP for OSX

Post by xss »

Hello jinesh,

whether options like the 'Options' lines or 'Allowoverride' work in the .htaccess files on your server, that should depend on some settings in your Apache's httpd.conf file, as far as I remember. So, if you are running a local Xampp installation, you should have total control over things like that -- given that you have administrative/superuser/root permissions on the machine, wanna fiddle with the config file and thus use non-default settings, and, most importantly, you know what you're doing.

Can't give you a better hint right now which httpd.conf lines are relevant; just wanted to add that here. :)
¿ן ʇ,uop 'spɹɐʍʞɔɐq ןןɐ ʇı ʇoƃ ן 'ɹɐǝp ɥo
jinesh
Posts: 3
Joined: Fri May 11, 2012 8:07 pm

Re: Installing on XAMPP for OSX

Post by jinesh »

Update -

Okay, following @XSS's suggestion I looked at the httpd.conf & php.ini files, two places where mod_rewrites can be controlled from...but it turns out it was xampp (v1.7.3) that has issues with mod_rewrites under certain server configurations (like mine - running xampp's php5 on OSX's default web server). Switched over to MAMP & everything works fine out of the box :roll:
wiz
Admin
Posts: 481
Joined: Sat Oct 30, 2010 12:23 am

Re: Installing on XAMPP for OSX

Post by wiz »

Glad you found a way to make it work. Hope we'll find a solution to make it work without the need for users to modify WonderCMS or XAMPP 1.7.3 (or hopefully it'll be solved in their next version).

Thanks for the great contribution and making WonderCMS a better tool for everyone!
Post Reply