Configuring Lighttpd

Welcome to the WonderCMS community. Anything goes, except for support requests.
User avatar
wiz
Admin
Posts: 540
Joined: Sat Oct 30, 2010 12:23 am

Re: Configuring Lighttpd

Post by wiz »

Can you also try the following (taken from the docs: https://github.com/robiso/wondercms/wik ... ver-config)

Code: Select all

               <rule name="rule 1S" stopProcessing="true">
                    <match url="^(.+)$" />
                    <conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
                    <action type="Rewrite" url="/index.php?page={R:1}" appendQueryString="true" />
                </rule>
Windsurfer
Posts: 9
Joined: Wed Nov 25, 2020 7:09 pm

Re: Configuring Lighttpd

Post by Windsurfer »

That was quick. I'll report back. It will be something basic, and I'm reading up what the rewrite and redirect commands do.
I'm using Perl based Regex at the moment.
User avatar
wiz
Admin
Posts: 540
Joined: Sat Oct 30, 2010 12:23 am

Re: Configuring Lighttpd

Post by wiz »

Looking forward to see if the above will fix it. Cheers for reporting back!
Windsurfer
Posts: 9
Joined: Wed Nov 25, 2020 7:09 pm

Re: Configuring Lighttpd

Post by Windsurfer »

After a mighty struggle with Lighttpd, I gave up and went to Apache2. The problem was not with WonderCMS.
User avatar
wiz
Admin
Posts: 540
Joined: Sat Oct 30, 2010 12:23 am

Re: Configuring Lighttpd

Post by wiz »

Really glad to hear that Windsurfer. Do you possibly have any heads up in regards to what could of been wrong with Lighttpd?

Thanks for getting back again with clarifications.
Post Reply